<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" xml:lang="en-US">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>The Hungry Oven | WestCoast Families</title>
<link rel="Shortcut Icon" href="http://westcoastfamilies.com/wp-content/themes/magazine/images/favicon.ico" type="image/x-icon" />
<link rel="stylesheet" href="http://westcoastfamilies.com/wp-content/themes/magazine/style.css" type="text/css" media="screen" />
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>
		<style type="text/css">
			#genesis-slider, #slides, .genesis-slider-wrap { height: 300px; width: 600px; }
			.slide-excerpt { width: 500px; }
			.slide-excerpt { bottom: 0; }
			.slide-excerpt { right: 0; }
			div.slider-next, div.slider-previous { top: 120px; }
		</style>
<!-- All in One SEO Pack 2.3.13.2 by Michael Torbert of Semper Fi Web Design[306,330] -->
<meta name="description"  content="by Parrish Wilson. (WestCoast Families events coordinator) Last night I was treated to a delicious Moroccan meal at The Hungry Oven. One might have thought" />

<link rel="canonical" href="http://westcoastfamilies.com/2012/07/the-hungry-oven/" />
			<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

			ga('create', 'UA-30551326-1', 'auto');
			
			ga('send', 'pageview');
			</script>
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WestCoast Families &raquo; Feed" href="http://westcoastfamilies.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="WestCoast Families &raquo; Comments Feed" href="http://westcoastfamilies.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="WestCoast Families &raquo; The Hungry Oven Comments Feed" href="http://westcoastfamilies.com/2012/07/the-hungry-oven/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/westcoastfamilies.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=1ff6b3b7d50a03d6dc549695f8325b67"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='font-awesome-css'  href='http://westcoastfamilies.com/wp-content/plugins/the-social-links/assets/css/font-awesome.min.css?ver=1ff6b3b7d50a03d6dc549695f8325b67' type='text/css' media='all' />
<link rel='stylesheet' id='the-social-links-style-css'  href='http://westcoastfamilies.com/wp-content/plugins/the-social-links/assets/css/style.css?ver=1ff6b3b7d50a03d6dc549695f8325b67' type='text/css' media='all' />
<link rel='stylesheet' id='events-manager-css'  href='http://westcoastfamilies.com/wp-content/plugins/events-manager/includes/css/events_manager.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='social-widget-css'  href='http://westcoastfamilies.com/wp-content/plugins/social-media-widget/social_widget.css?ver=1ff6b3b7d50a03d6dc549695f8325b67' type='text/css' media='all' />
<link rel='stylesheet' id='wp-fullcalendar-css'  href='http://westcoastfamilies.com/wp-content/plugins/wp-fullcalendar/includes/css/main.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-css'  href='http://westcoastfamilies.com/wp-content/plugins/wp-fullcalendar/includes/css/jquery-ui/ui-lightness/jquery-ui.min.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-theme-css'  href='http://westcoastfamilies.com/wp-content/plugins/wp-fullcalendar/includes/css/jquery-ui/ui-lightness/theme.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='slider_styles-css'  href='http://westcoastfamilies.com/wp-content/plugins/genesis-slider/style.css?ver=0.9.6' type='text/css' media='all' />
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/ui/sortable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/wp-a11y.min.js?ver=1ff6b3b7d50a03d6dc549695f8325b67'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EM = {"ajaxurl":"http:\/\/westcoastfamilies.com\/wp-admin\/admin-ajax.php","locationajaxurl":"http:\/\/westcoastfamilies.com\/wp-admin\/admin-ajax.php?action=locations_search","firstDay":"1","locale":"en","dateFormat":"dd\/mm\/yy","ui_css":"http:\/\/westcoastfamilies.com\/wp-content\/plugins\/events-manager\/includes\/css\/jquery-ui.min.css","show24hours":"0","is_ssl":"","bookingInProgress":"Please wait while the booking is being submitted.","tickets_save":"Save Ticket","bookingajaxurl":"http:\/\/westcoastfamilies.com\/wp-admin\/admin-ajax.php","bookings_export_save":"Export Bookings","bookings_settings_save":"Save Settings","booking_delete":"Are you sure you want to delete?","booking_offset":"30","bb_full":"Sold Out","bb_book":"Book Now","bb_booking":"Booking...","bb_booked":"Booking Submitted","bb_error":"Booking Error. Try again?","bb_cancel":"Cancel","bb_canceling":"Canceling...","bb_cancelled":"Cancelled","bb_cancel_error":"Cancellation Error. Try again?","txt_search":"Search","txt_searching":"Searching...","txt_loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-content/plugins/events-manager/includes/js/events-manager.js?ver=5.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var samAjax = {"ajaxurl":"http:\/\/westcoastfamilies.com\/wp-content\/plugins\/simple-ads-manager\/sam-ajax.php","loadurl":"http:\/\/westcoastfamilies.com\/wp-content\/plugins\/simple-ads-manager\/sam-ajax-loader.php","load":"","mailer":"1","clauses":"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","doStats":"1","container":"sam-container","place":"sam-place","ad":"sam-ad"};
/* ]]> */
</script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-content/plugins/simple-ads-manager/js/sam-layout.min.js?ver=2.9.8.125'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/jquery/ui/selectmenu.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPFC = {"ajaxurl":"http:\/\/westcoastfamilies.com\/wp-admin\/admin-ajax.php","firstDay":"1","wpfc_theme":"1","wpfc_limit":"3","wpfc_limit_txt":"more ...","timeFormat":"h(:mm)t","defaultView":"month","weekends":"true","header":{"left":"prev,next today","center":"title","right":"month,basicWeek,basicDay"},"wpfc_qtips":"1","wpfc_qtips_classes":"ui-tooltip-light ui-tooltip-shadow","wpfc_qtips_my":"top center","wpfc_qtips_at":"bottom center"};
/* ]]> */
</script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-content/plugins/wp-fullcalendar/includes/js/main.js?ver=1.1'></script>
<style type="text/css">img.nothumb{border:0;margin:0 0 0 2px !important;}</style>
<!-- Tweet This v1.8.3 b037 mode alpha zeta -->
<link rel='https://api.w.org/' href='http://westcoastfamilies.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://westcoastfamilies.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://westcoastfamilies.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='The 2012 Reader&#8217;s Choice Awards are here!' href='http://westcoastfamilies.com/2012/07/the-2012-readers-choice-awards-are-here/' />
<link rel='next' title='Save energy and $ at home when you head out of town.' href='http://westcoastfamilies.com/2012/08/save-energy-and-at-home-when-you-head-out-of-town/' />

<link rel='shortlink' href='https://is.gd/BusxfN' />
<link rel="alternate" type="application/json+oembed" href="http://westcoastfamilies.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwestcoastfamilies.com%2F2012%2F07%2Fthe-hungry-oven%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://westcoastfamilies.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwestcoastfamilies.com%2F2012%2F07%2Fthe-hungry-oven%2F&#038;format=xml" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//westcoastfamilies.com/?wordfence_logHuman=1&hid=7644D3441E5E6F31483927BF1BD9192A');
</script><meta property='og:title' content='The Hungry Oven'/>
<meta property='og:url' content='http://westcoastfamilies.com/2012/07/the-hungry-oven/'/>
<meta property='og:site_name' content='WestCoast Families'/>
<meta property='og:type' content='website'/>
<meta property='fb:app_id' content='null'/>
<meta property='fb:admins' content=''/>
<link rel="canonical" href="http://westcoastfamilies.com/2012/07/the-hungry-oven/" />
<style type="text/css">#header { background: url(http://westcoastfamilies.com/wp-content/uploads/2012/11/wcf-logo-banner.jpg) no-repeat; } #title a, #title a:hover, #description { color: #blank; }</style><!-- BEGIN GADWP v5.1 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-7748139-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
</head>
<body class="post-template-default single single-post postid-1249 single-format-standard header-image nolayout">
<div class="navcontainer"><div id="nav"><div class="wrap"><ul id="menu-top" class="nav superfish"><li id="menu-item-1412" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1412"><a href="http://westcoastfamilies.com/contact/">Contact</a></li><li class="separator"></li>
<li id="menu-item-1411" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1411"><a href="http://westcoastfamilies.com/advertising/">Advertising</a></li><li class="separator"></li>
<li id="menu-item-1413" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1413"><a href="http://westcoastfamilies.com/where-to-pick-us-up/">Where to pick us up</a></li><li class="separator"></li>
<li id="menu-item-1410" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1410"><a href="http://westcoastfamilies.com/about/">About Us</a></li><li class="separator"></li>
<li id="menu-item-1414" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1414"><a href="#">Editorial</a>
<ul  class="sub-menu">
	<li id="menu-item-1415" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1415"><a href="http://westcoastfamilies.com/editorial-calendar/">Editorial Calendar</a></li><li class="separator"></li>
	<li id="menu-item-1417" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1417"><a href="http://westcoastfamilies.com/past-issues/">Past Issues</a></li><li class="separator"></li>
	<li id="menu-item-1416" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1416"><a href="http://westcoastfamilies.com/editorial_guidelines/">Guidelines</a></li><li class="separator"></li>
</ul></li><li class="separator"></li>
</ul></div><!-- end .wrap --></div></div><div id="wrap">
<div id="header"><div class="wrap"><div id="title-area"><p id="title"><a href="http://westcoastfamilies.com/" title="WestCoast Families">WestCoast Families</a></p><p id="description">The local guide for active, urban families</p></div><!-- end #title-area --><div class="widget-area"><div id="text-3" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"></div>
		</div></div>
</div><!-- end .widget_area --></div><!-- end .wrap --></div><!--end #header--><div id="subnav"><div class="wrap"><ul id="menu-main" class="nav superfish"><li id="menu-item-12" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-12"><a href="http://westcoastfamilies.com">Home</a></li>
<li id="menu-item-927" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-927"><a href="http://westcoastfamilies.com/blog/">Blog</a></li>
<li id="menu-item-822" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-822"><a href="http://westcoastfamilies.com/events_calendar/">Events</a></li>
<li id="menu-item-942" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-942"><a href="http://westcoastfamilies.com/listings/">Listings</a></li>
<li id="menu-item-21" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21"><a href="http://westcoastfamilies.com/past-issues/">Past Issues</a></li>
<li id="menu-item-32" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32"><a href="http://westcoastfamilies.com/contest/">Contests</a></li>
<li id="menu-item-3621" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3621"><a href="http://westcoastfamilies.com/baby-guide/">Baby Guide</a></li>
</ul></div><!-- end .wrap --></div><div id="inner"><div class="wrap">	<div id="content-sidebar-wrap">
				<div id="content" class="hfeed">
				<div class="post-1249 post type-post status-publish format-standard hentry category-uncategorized">

				<h1 class="entry-title">The Hungry Oven</h1>
		
		<div class="post-info"><span class="date published time" title="2012-07-26T21:37:33-0700">July 26, 2012</span>  By <span class="author vcard"><span class="fn"><a href="http://westcoastfamilies.com/author/kids_mag/" title="Posts by WCFM" rel="author">WCFM</a></span></span>  </div>		<div class="entry-content">
			<p><a href="http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-1.jpg"><img class=" wp-image-1250 alignright" title="Photo 1" src="http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-1-158x300.jpg" alt="" width="105" height="200" srcset="http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-1-158x300.jpg 158w, http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-1-539x1024.jpg 539w, http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-1.jpg 1576w" sizes="(max-width: 105px) 100vw, 105px" /></a>by Parrish Wilson.<em>  (WestCoast Families events coordinator)</em></p>
<p>Last night I was treated to a delicious Moroccan meal at The Hungry Oven. One might have thought the beautiful meal presented to us had been cooked by professional chefs but the truth is, it was cooked by kids!</p>
<p>The appetizer for the evenings was Crudite with Moroccan Hummus and Grilled Flatbread (cooked hummus which was honestly better than any hummus I’ve ever had) and veggie sticks. I was completely smitten with the presentation of these and will absolutely replicate the idea at my own house in the near future.</p>
<p>The table was then set with Moroccan Couscous Salad and Tabouli Casserole. Gus, the prodigy of The Hungry Oven who competed as the youngest competitor ever (13!) in BC <a href="http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-2.jpg"><img class="alignleft  wp-image-1251" title="Photo 2" src="http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-2-300x151.jpg" alt="" width="224" height="112" srcset="http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-2-300x151.jpg 300w, http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-2-1024x516.jpg 1024w, http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-2-600x300.jpg 600w" sizes="(max-width: 224px) 100vw, 224px" /></a>Chef’s Association’s Teen Cooking Contest, served our meal. He told us of dreams to have his own restaurant one day and about how he convinced his mom to switch to a gas range with their current kitchen renovation.</p>
<p><a href="http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-3.jpg"><img class="wp-image-1252 alignright" title="Photo 3" src="http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-3-300x160.jpg" alt="" width="220" height="117" srcset="http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-3-300x160.jpg 300w, http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-3-1024x546.jpg 1024w" sizes="(max-width: 220px) 100vw, 220px" /></a></p>
<p>The meal didn’t end there. We watched with anticipation as the kids plated the Egyptian Orange Cake.  This was a perfect end to a delicious and filling meal (yes, I had seconds).</p>
<p>The Hungry Oven is the awesome idea of Debby Tonn and runs cooking camps for kids in North Vancouver. The space has been designed with families in mind – kids as young as 3.5 years old can cook in the kinder kitchen. This kitchen has convection ovens and safe knives – it’s almost impossible for anyone to get hurt. The older kids cook in one of two real commercial kitchens, learning skills that can help them at home and in future jobs.<a href="http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-4.jpg"><img class="wp-image-1253 alignleft" title="Photo 4" src="http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-4-300x174.jpg" alt="" width="232" height="134" srcset="http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-4-300x174.jpg 300w, http://westcoastfamilies.com/wp-content/uploads/2012/07/Photo-4-1024x597.jpg 1024w" sizes="(max-width: 232px) 100vw, 232px" /></a></p>
<p>Even the parents have a place all their own: a parent’s lounge where you can sit back, enjoy a coffee and watch your kids cook up a storm on the live streaming video feed. But actually parents can get their cook on too. Debby offers Girls Night Out, Date Night, Book Club, Special Events and even Team Building options for those of us too old to join the day camps.</p>
<p>Perhaps the best part of the night was when the kids told us how they now cook at home for their parents… when can I enroll my son?</p>
<p><a href="http://www.thehungryoven.com">www.thehungryoven.com</a></p>
<div class="tweetthis" style="text-align:left;"><p> <a target="_blank" rel="nofollow" class="tt" href="http://twitter.com/share?url=http://westcoastfamilies.com/2012/07/the-hungry-oven/&text=The+Hungry+Oven&via=tweetthisplugin&related=richardxthripp%2Ctweetthisplugin" title="Post to Twitter"><img class="nothumb" src="http://westcoastfamilies.com/wp-content/plugins/tweet-this/icons/en/twitter/tt-twitter-big1.png" alt="Post to Twitter" /></a> <a target="_blank" rel="nofollow" class="tt" href="http://twitter.com/share?url=http://westcoastfamilies.com/2012/07/the-hungry-oven/&text=The+Hungry+Oven&via=tweetthisplugin&related=richardxthripp%2Ctweetthisplugin" title="Post to Twitter"> </a></p></div><div class='wpfblike' style='height: 22px;'><iframe src='http://www.facebook.com/plugins/like.php?href=http://westcoastfamilies.com/2012/07/the-hungry-oven/&amp;layout=button_count&amp;show_faces=false&amp;width=120&amp;action=like&amp;colorscheme=light&amp;send=true' scrolling='no' frameborder='0' allowTransparency='true' style='border:none; overflow:hidden; width:120px;'></iframe></div>		</div><!-- end .entry-content -->
		<div class="post-meta"><span class="categories"> <img src="/wp-content/themes/genesis/images/folder.png" align="top"> Filed Under: <a href="http://westcoastfamilies.com/category/uncategorized/" rel="category tag">Uncategorized</a></span>   </div>
	</div><!-- end .postclass -->
<div class="author-box"><div><img alt='' src='http://1.gravatar.com/avatar/a9a6dd62049fcb9d34d0381807923290?s=70&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/a9a6dd62049fcb9d34d0381807923290?s=140&amp;d=mm&amp;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /> <strong>About WCFM</strong><br /></div></div><!-- end .authorbox-->		</div><!-- end #content -->
		<div id="sidebar" class="sidebar widget-area">
<div id="search-4" class="widget widget_search"><div class="widget-wrap">
		<form method="get" class="searchform" action="http://westcoastfamilies.com/" >
			<input type="text" value="Search this website &hellip;" name="s" class="s" onfocus="if (this.value == 'Search this website &hellip;') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search this website &hellip;';}" />
			<input type="submit" class="searchsubmit" value="Search" />
		</form>
	</div></div>
<div id="social-widget-4" class="widget Social_Widget"><div class="widget-wrap"><h4 class="widgettitle">Follow Us!</h4>
<div class="socialmedia-buttons smw_left"><a href="https://www.facebook.com/westcoastfamilies/" rel="nofollow" target="_blank"><img width="32" height="32" src="http://westcoastfamilies.com/wp-content/plugins/social-media-widget/images/default/32/facebook.png" 
				alt="Follow Us on Facebook" 
				title="Follow Us on Facebook" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="https://twitter.com/wcfmag" rel="nofollow" target="_blank"><img width="32" height="32" src="http://westcoastfamilies.com/wp-content/plugins/social-media-widget/images/default/32/twitter.png" 
				alt="Follow Us on Twitter" 
				title="Follow Us on Twitter" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="https://www.instagram.com/westcoastfamilies/" rel="nofollow" target="_blank"><img width="32" height="32" src="http://westcoastfamilies.com/wp-content/plugins/social-media-widget/images/default/32/instagram.png" 
				alt="Follow Us on Instagram" 
				title="Follow Us on Instagram" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="https://www.pinterest.com/wcfmag/" rel="nofollow" target="_blank"><img width="32" height="32" src="http://westcoastfamilies.com/wp-content/plugins/social-media-widget/images/default/32/pinterest.png" 
				alt="Follow Us on Pinterest" 
				title="Follow Us on Pinterest" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a></div></div></div>
<div id="featured-page-13" class="widget featuredpage"><div class="widget-wrap"><h4 class="widgettitle">Contests</h4>
<div class="post-27 page type-page status-publish has-post-thumbnail hentry"><a href="http://westcoastfamilies.com/contest/" title="Contests" class=""><img width="280" height="150" src="http://westcoastfamilies.com/wp-content/uploads/2012/01/entertowin-logo.jpg" class="attachment-home-bottom size-home-bottom" alt="" /></a></div><!--end post_class()-->

</div></div>
<div id="featured-post-4" class="widget featuredpost"><div class="widget-wrap"><h4 class="widgettitle">Recent Posts</h4>
<div class="post-5266 post type-post status-publish format-standard hentry category-business category-moms category-women tag-award tag-business tag-moms-2 tag-women-2"><a href="http://westcoastfamilies.com/2017/05/michelle-pockey-leadership-award-accepting-applications/" title="Michelle Pockey Leadership Award Accepting Applications!" class=""></a><h2 class="title"><a href="http://westcoastfamilies.com/2017/05/michelle-pockey-leadership-award-accepting-applications/" title="Michelle Pockey Leadership Award Accepting Applications!">Michelle Pockey Leadership Award Accepting Applications!</a></h2></div><!--end post_class()-->

<div class="post-5256 post type-post status-publish format-standard hentry category-events category-events-vancouver tag-canada tag-goodturn tag-scouts"><a href="http://westcoastfamilies.com/2017/05/goodturn-with-scouts-canada/" title="#GoodTurn with Scouts Canada" class=""></a><h2 class="title"><a href="http://westcoastfamilies.com/2017/05/goodturn-with-scouts-canada/" title="#GoodTurn with Scouts Canada">#GoodTurn with Scouts Canada</a></h2></div><!--end post_class()-->

<div class="post-5258 post type-post status-publish format-standard hentry category-in-this-issue category-moms category-shopping tag-cool tag-finds tag-stroller"><a href="http://westcoastfamilies.com/2017/04/cool-finds-for-travel/" title="Cool Finds for Travel!" class=""></a><h2 class="title"><a href="http://westcoastfamilies.com/2017/04/cool-finds-for-travel/" title="Cool Finds for Travel!">Cool Finds for Travel!</a></h2></div><!--end post_class()-->

</div></div>
<div id="archives-6" class="widget widget_archive"><div class="widget-wrap"><h4 class="widgettitle">Archives</h4>
		<label class="screen-reader-text" for="archives-dropdown-6">Archives</label>
		<select id="archives-dropdown-6" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://westcoastfamilies.com/2017/05/'> May 2017 </option>
	<option value='http://westcoastfamilies.com/2017/04/'> April 2017 </option>
	<option value='http://westcoastfamilies.com/2017/03/'> March 2017 </option>
	<option value='http://westcoastfamilies.com/2017/02/'> February 2017 </option>
	<option value='http://westcoastfamilies.com/2017/01/'> January 2017 </option>
	<option value='http://westcoastfamilies.com/2016/12/'> December 2016 </option>
	<option value='http://westcoastfamilies.com/2016/11/'> November 2016 </option>
	<option value='http://westcoastfamilies.com/2016/10/'> October 2016 </option>
	<option value='http://westcoastfamilies.com/2016/09/'> September 2016 </option>
	<option value='http://westcoastfamilies.com/2016/08/'> August 2016 </option>
	<option value='http://westcoastfamilies.com/2016/07/'> July 2016 </option>
	<option value='http://westcoastfamilies.com/2016/06/'> June 2016 </option>
	<option value='http://westcoastfamilies.com/2016/05/'> May 2016 </option>
	<option value='http://westcoastfamilies.com/2016/04/'> April 2016 </option>
	<option value='http://westcoastfamilies.com/2016/03/'> March 2016 </option>
	<option value='http://westcoastfamilies.com/2016/02/'> February 2016 </option>
	<option value='http://westcoastfamilies.com/2016/01/'> January 2016 </option>
	<option value='http://westcoastfamilies.com/2015/12/'> December 2015 </option>
	<option value='http://westcoastfamilies.com/2015/11/'> November 2015 </option>
	<option value='http://westcoastfamilies.com/2015/10/'> October 2015 </option>
	<option value='http://westcoastfamilies.com/2015/09/'> September 2015 </option>
	<option value='http://westcoastfamilies.com/2015/08/'> August 2015 </option>
	<option value='http://westcoastfamilies.com/2015/07/'> July 2015 </option>
	<option value='http://westcoastfamilies.com/2015/06/'> June 2015 </option>
	<option value='http://westcoastfamilies.com/2015/05/'> May 2015 </option>
	<option value='http://westcoastfamilies.com/2015/04/'> April 2015 </option>
	<option value='http://westcoastfamilies.com/2015/03/'> March 2015 </option>
	<option value='http://westcoastfamilies.com/2015/02/'> February 2015 </option>
	<option value='http://westcoastfamilies.com/2015/01/'> January 2015 </option>
	<option value='http://westcoastfamilies.com/2014/12/'> December 2014 </option>
	<option value='http://westcoastfamilies.com/2014/11/'> November 2014 </option>
	<option value='http://westcoastfamilies.com/2014/10/'> October 2014 </option>
	<option value='http://westcoastfamilies.com/2014/09/'> September 2014 </option>
	<option value='http://westcoastfamilies.com/2014/08/'> August 2014 </option>
	<option value='http://westcoastfamilies.com/2014/07/'> July 2014 </option>
	<option value='http://westcoastfamilies.com/2014/06/'> June 2014 </option>
	<option value='http://westcoastfamilies.com/2014/05/'> May 2014 </option>
	<option value='http://westcoastfamilies.com/2014/04/'> April 2014 </option>
	<option value='http://westcoastfamilies.com/2014/03/'> March 2014 </option>
	<option value='http://westcoastfamilies.com/2014/02/'> February 2014 </option>
	<option value='http://westcoastfamilies.com/2014/01/'> January 2014 </option>
	<option value='http://westcoastfamilies.com/2013/12/'> December 2013 </option>
	<option value='http://westcoastfamilies.com/2013/11/'> November 2013 </option>
	<option value='http://westcoastfamilies.com/2013/10/'> October 2013 </option>
	<option value='http://westcoastfamilies.com/2013/09/'> September 2013 </option>
	<option value='http://westcoastfamilies.com/2013/08/'> August 2013 </option>
	<option value='http://westcoastfamilies.com/2013/07/'> July 2013 </option>
	<option value='http://westcoastfamilies.com/2013/06/'> June 2013 </option>
	<option value='http://westcoastfamilies.com/2013/05/'> May 2013 </option>
	<option value='http://westcoastfamilies.com/2013/04/'> April 2013 </option>
	<option value='http://westcoastfamilies.com/2013/03/'> March 2013 </option>
	<option value='http://westcoastfamilies.com/2013/02/'> February 2013 </option>
	<option value='http://westcoastfamilies.com/2013/01/'> January 2013 </option>
	<option value='http://westcoastfamilies.com/2012/12/'> December 2012 </option>
	<option value='http://westcoastfamilies.com/2012/11/'> November 2012 </option>
	<option value='http://westcoastfamilies.com/2012/10/'> October 2012 </option>
	<option value='http://westcoastfamilies.com/2012/09/'> September 2012 </option>
	<option value='http://westcoastfamilies.com/2012/08/'> August 2012 </option>
	<option value='http://westcoastfamilies.com/2012/07/'> July 2012 </option>
	<option value='http://westcoastfamilies.com/2012/06/'> June 2012 </option>
	<option value='http://westcoastfamilies.com/2012/05/'> May 2012 </option>
	<option value='http://westcoastfamilies.com/2012/04/'> April 2012 </option>
	<option value='http://westcoastfamilies.com/2012/03/'> March 2012 </option>
	<option value='http://westcoastfamilies.com/2012/02/'> February 2012 </option>
	<option value='http://westcoastfamilies.com/2012/01/'> January 2012 </option>
	<option value='http://westcoastfamilies.com/2011/12/'> December 2011 </option>
	<option value='http://westcoastfamilies.com/2011/11/'> November 2011 </option>
	<option value='http://westcoastfamilies.com/2011/10/'> October 2011 </option>
	<option value='http://westcoastfamilies.com/2011/09/'> September 2011 </option>
	<option value='http://westcoastfamilies.com/2011/08/'> August 2011 </option>
	<option value='http://westcoastfamilies.com/2011/07/'> July 2011 </option>
	<option value='http://westcoastfamilies.com/2011/06/'> June 2011 </option>
	<option value='http://westcoastfamilies.com/2011/05/'> May 2011 </option>
	<option value='http://westcoastfamilies.com/2011/04/'> April 2011 </option>
	<option value='http://westcoastfamilies.com/2011/03/'> March 2011 </option>
	<option value='http://westcoastfamilies.com/2011/02/'> February 2011 </option>
	<option value='http://westcoastfamilies.com/2011/01/'> January 2011 </option>
	<option value='http://westcoastfamilies.com/2010/12/'> December 2010 </option>
	<option value='http://westcoastfamilies.com/2010/11/'> November 2010 </option>
	<option value='http://westcoastfamilies.com/2010/10/'> October 2010 </option>
	<option value='http://westcoastfamilies.com/2010/09/'> September 2010 </option>
	<option value='http://westcoastfamilies.com/2010/08/'> August 2010 </option>
	<option value='http://westcoastfamilies.com/2010/07/'> July 2010 </option>
	<option value='http://westcoastfamilies.com/2010/06/'> June 2010 </option>
	<option value='http://westcoastfamilies.com/2010/05/'> May 2010 </option>
	<option value='http://westcoastfamilies.com/2010/04/'> April 2010 </option>
	<option value='http://westcoastfamilies.com/2009/11/'> November 2009 </option>
	<option value='http://westcoastfamilies.com/2009/10/'> October 2009 </option>
	<option value='http://westcoastfamilies.com/2009/05/'> May 2009 </option>
	<option value='http://westcoastfamilies.com/2009/04/'> April 2009 </option>
	<option value='http://westcoastfamilies.com/2009/03/'> March 2009 </option>
	<option value='http://westcoastfamilies.com/2009/02/'> February 2009 </option>
	<option value='http://westcoastfamilies.com/2008/10/'> October 2008 </option>
	<option value='http://westcoastfamilies.com/2008/09/'> September 2008 </option>
	<option value='http://westcoastfamilies.com/2008/07/'> July 2008 </option>
	<option value='http://westcoastfamilies.com/2008/06/'> June 2008 </option>

		</select>
		</div></div>
</div>	</div><!-- end #content-sidebar-wrap -->
	<div id="sidebar-alt" class="sidebar widget-area">
</div></div><!-- end .wrap --></div><!-- end #inner --><div id="footer" class="footer"><div class="wrap"><div class="gototop">
<p><a rel="nofollow" href="#wrap" >Return to top of page</a></p></div>
<div class="creds"><p>Copyright &copy; 2017 &middot; All Right Reserved</p></div>
</div><!-- end .wrap --></div><!-- end #footer -->
</div><!-- end #wrap -->
<script type='text/javascript'>jQuery(document).ready(function($) {$(".myController").jFlow({controller: ".jFlowControl",slideWrapper : "#jFlowSlider",slides: "#slides",selectedWrapper: "jFlowSelected",width: "600px",height: "300px",timer: 4000,duration: 1000,loop: 1,effect: "left",prev: ".slider-previous",next: ".slider-next",auto: true});});</script><script type='text/javascript' src='http://westcoastfamilies.com/wp-content/themes/genesis/lib/js/menu/superfish.js?ver=1.4.8'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-content/themes/genesis/lib/js/menu/superfish.args.js?ver=1.7'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-content/plugins/genesis-slider/js/jflow.plus.js?ver=0.9.6'></script>
<script type='text/javascript' src='http://westcoastfamilies.com/wp-includes/js/wp-embed.min.js?ver=1ff6b3b7d50a03d6dc549695f8325b67'></script>

</body>
</html>